KasmVNC/contrib/packages/rpm/el5/SOURCES/tigervnc-2b76d02.patch
2020-09-20 12:16:44 +00:00

24 lines
875 B
Diff

From 2b76d028b0253be7c4496840fcd2e0fb47c0794e Mon Sep 17 00:00:00 2001
From: Pierre Ossman <ossman@cendio.se>
Date: Mon, 15 Dec 2014 10:52:43 +0100
Subject: [PATCH] Band aid to work around inluding C headers in C++ code
---
unix/xserver/hw/vnc/Makefile.am | 3 +++
1 file changed, 3 insertions(+)
diff --git a/unix/xserver/hw/vnc/Makefile.am b/unix/xserver/hw/vnc/Makefile.am
index 9885b8a..372a57f 100644
--- a/unix/xserver/hw/vnc/Makefile.am
+++ b/unix/xserver/hw/vnc/Makefile.am
@@ -7,6 +7,9 @@ NETWORK_LIB=$(LIB_DIR)/network/libnetwork.la
XREGION_LIB=$(LIB_DIR)/Xregion/libXregion.la
COMMON_LIBS=$(NETWORK_LIB) $(RFB_LIB) $(RDR_LIB) $(XREGION_LIB)
+# Hack to get the C headers to work when included from C++ code
+AM_CXXFLAGS = -fpermissive
+
noinst_LTLIBRARIES = libvnccommon.la
HDRS = RegionHelper.h vncExtInit.h vncHooks.h XserverDesktop.h xorg-version.h \