flakelight/builtinModules/bundlers.nix
Archit Gupta 543e3aaa4d Replace nixpkgs nullOr type with custom type
`nullOr`'s merge function requires definitions to all be null or all be
non-null. It was being used where the intent was that null be used as a
value representing unset, and as such the merge should return null if
all definitions are null and ignore nulls otherwise. This adds a type
with that merge semantics.
2024-02-07 01:49:29 -08:00

40 lines
972 B
Nix

# flakelight -- Framework for simplifying flake setup
# Copyright (C) 2023 Archit Gupta <archit@accelbread.com>
# SPDX-License-Identifier: MIT
{ config, lib, flakelight, genSystems, ... }:
let
inherit (lib) isFunction mapAttrs mkMerge mkOption mkIf;
inherit (lib.types) lazyAttrsOf;
inherit (flakelight.types) function nullable optFunctionTo;
wrapBundler = pkgs: bundler: drv:
if isFunction (bundler (pkgs // drv))
then bundler pkgs drv
else bundler drv;
in
{
options = {
bundler = mkOption {
type = nullable function;
default = null;
};
bundlers = mkOption {
type = nullable (optFunctionTo (lazyAttrsOf function));
default = null;
};
};
config = mkMerge [
(mkIf (config.bundler != null) {
bundlers.default = config.bundler;
})
(mkIf (config.bundlers != null) {
outputs.bundlers = genSystems (pkgs:
mapAttrs (_: wrapBundler pkgs) (config.bundlers pkgs));
})
];
}