mirror of
https://github.com/nix-community/flakelight.git
synced 2024-11-21 15:03:15 +01:00
589ee5ba7a
Many attributes can take moduleArgs when auto-loaded in order to facilitate access to them from other files. Those same attributes could not take moduleArgs when included directly, which was inconsistent. With this change, all attributes that could take moduleArgs when auto-loaded can now always do so. Auto-loading no longer needs special cases.
21 lines
487 B
Nix
21 lines
487 B
Nix
# flakelight -- Framework for simplifying flake setup
|
|
# Copyright (C) 2023 Archit Gupta <archit@accelbread.com>
|
|
# SPDX-License-Identifier: MIT
|
|
|
|
{ config, lib, flakelight, moduleArgs, ... }:
|
|
let
|
|
inherit (lib) mkOption mkIf;
|
|
inherit (lib.types) attrsOf raw;
|
|
inherit (flakelight.types) optCallWith;
|
|
in
|
|
{
|
|
options.lib = mkOption {
|
|
type = optCallWith moduleArgs (attrsOf raw);
|
|
default = { };
|
|
};
|
|
|
|
config.outputs = mkIf (config.lib != { }) {
|
|
inherit (config) lib;
|
|
};
|
|
}
|