flakelight/builtinModules/overlays.nix
Archit Gupta 543e3aaa4d Replace nixpkgs nullOr type with custom type
`nullOr`'s merge function requires definitions to all be null or all be
non-null. It was being used where the intent was that null be used as a
value representing unset, and as such the merge should return null if
all definitions are null and ignore nulls otherwise. This adds a type
with that merge semantics.
2024-02-07 01:49:29 -08:00

34 lines
757 B
Nix

# flakelight -- Framework for simplifying flake setup
# Copyright (C) 2023 Archit Gupta <archit@accelbread.com>
# SPDX-License-Identifier: MIT
{ config, lib, flakelight, moduleArgs, ... }:
let
inherit (lib) mkMerge mkOption mkIf;
inherit (lib.types) lazyAttrsOf;
inherit (flakelight.types) nullable optCallWith overlay;
in
{
options = {
overlay = mkOption {
type = nullable overlay;
default = null;
};
overlays = mkOption {
type = optCallWith moduleArgs (lazyAttrsOf overlay);
default = { };
};
};
config = mkMerge [
(mkIf (config.overlay != null) {
overlays.default = config.overlay;
})
(mkIf (config.overlays != { }) {
outputs = { inherit (config) overlays; };
})
];
}