flakelight/builtinModules/templates.nix
Archit Gupta 543e3aaa4d Replace nixpkgs nullOr type with custom type
`nullOr`'s merge function requires definitions to all be null or all be
non-null. It was being used where the intent was that null be used as a
value representing unset, and as such the merge should return null if
all definitions are null and ignore nulls otherwise. This adds a type
with that merge semantics.
2024-02-07 01:49:29 -08:00

47 lines
1.2 KiB
Nix

# flakelight -- Framework for simplifying flake setup
# Copyright (C) 2023 Archit Gupta <archit@accelbread.com>
# SPDX-License-Identifier: MIT
{ config, lib, flakelight, moduleArgs, ... }:
let
inherit (builtins) isPath isString;
inherit (lib) mkOption mkOptionType mkIf mkMerge;
inherit (lib.types) lazyAttrsOf;
inherit (lib.options) mergeEqualOption;
inherit (flakelight.types) nullable optCallWith;
template = mkOptionType {
name = "template";
description = "template definition";
descriptionClass = "noun";
check = x: (x ? path) && (isPath x.path) &&
(x ? description) && (isString x.description) &&
((! x ? welcomeText) || (isString x.welcomeText));
merge = mergeEqualOption;
};
in
{
options = {
template = mkOption {
type = nullable (optCallWith moduleArgs template);
default = null;
};
templates = mkOption {
type = optCallWith moduleArgs
(lazyAttrsOf (optCallWith moduleArgs template));
default = { };
};
};
config = mkMerge [
(mkIf (config.template != null) {
templates.default = config.template;
})
(mkIf (config.templates != { }) {
outputs = { inherit (config) templates; };
})
];
}