nix-config/.archlinux/PKGBUILDs/tari-util-xeventbind/Makefile
Donovan Glover 74b6975ba5
PKGBUILDs: Add tari-util-xeventbind
xeventbind is a useful program that lets you run any command on
resolution change, similar to how GNOME on Wayland is able to change
scaling on on resolution change, but not exactly.

Since we're still using X, existing programs are not affected; they
have to be restarted instead.
2018-11-28 20:45:39 -05:00

18 lines
212 B
Makefile
Vendored

CC=gcc
CFLAGS=-O2
LIBS=-lX11
OBJ=main.o xeb_handler.o
.PHONY: all clean
all: xeventbind
xeventbind: $(OBJ)
$(CC) -o $@ $^ $(LIBS) $(CFLAGS)
%.o: %.c
$(CC) -c -o $@ $< $(CLAGS)
clean:
rm -f xeventbind *.o