mirror of
https://github.com/donovanglover/nix-config.git
synced 2024-11-23 16:54:27 +01:00
74b6975ba5
xeventbind is a useful program that lets you run any command on resolution change, similar to how GNOME on Wayland is able to change scaling on on resolution change, but not exactly. Since we're still using X, existing programs are not affected; they have to be restarted instead.
18 lines
212 B
Makefile
Vendored
18 lines
212 B
Makefile
Vendored
CC=gcc
|
|
CFLAGS=-O2
|
|
|
|
LIBS=-lX11
|
|
OBJ=main.o xeb_handler.o
|
|
|
|
.PHONY: all clean
|
|
all: xeventbind
|
|
|
|
xeventbind: $(OBJ)
|
|
$(CC) -o $@ $^ $(LIBS) $(CFLAGS)
|
|
|
|
%.o: %.c
|
|
$(CC) -c -o $@ $< $(CLAGS)
|
|
|
|
clean:
|
|
rm -f xeventbind *.o
|