mirror of
https://github.com/donovanglover/nix-config.git
synced 2024-11-21 15:53:32 +01:00
911547d78c
Actually necessary to prevent indent lines from occasionally showing up as 2 instead of 4. Also fixes shiftwidth.
25 lines
389 B
Nix
25 lines
389 B
Nix
{
|
|
editorconfig = {
|
|
enable = true;
|
|
|
|
settings = {
|
|
"*" = {
|
|
charset = "utf-8";
|
|
end_of_line = "lf";
|
|
insert_final_newline = true;
|
|
indent_size = 2;
|
|
indent_style = "space";
|
|
trim_trailing_whitespace = true;
|
|
};
|
|
|
|
"*.md" = {
|
|
indent_size = 4;
|
|
};
|
|
|
|
"*.rs" = {
|
|
indent_size = 4;
|
|
};
|
|
};
|
|
};
|
|
}
|