mirror of
https://github.com/donovanglover/nix-config.git
synced 2024-11-21 15:53:32 +01:00
8438c07ab1
It's better to use fish abbreviations so it's easier to remember what the aliases actually do.
67 lines
1.3 KiB
Nix
67 lines
1.3 KiB
Nix
{ pkgs, ... }:
|
|
|
|
{
|
|
home.packages = with pkgs; [
|
|
tig
|
|
mgitstatus
|
|
];
|
|
|
|
xdg.configFile."tig/config".text = ''
|
|
color cursor black green bold
|
|
color title-focus black blue bold
|
|
color title-blur black blue bold
|
|
'';
|
|
|
|
programs.git = {
|
|
enable = true;
|
|
|
|
attributes = [ "*.lockb binary diff=lockb" ];
|
|
|
|
extraConfig = {
|
|
include.path = "~/.gituser";
|
|
commit.gpgsign = true;
|
|
|
|
diff.lockb = {
|
|
textconv = "bun";
|
|
binary = true;
|
|
};
|
|
|
|
core = {
|
|
editor = "nvim";
|
|
autocrlf = false;
|
|
quotePath = false;
|
|
};
|
|
|
|
push.default = "simple";
|
|
pull.rebase = true;
|
|
fetch.prune = true;
|
|
branch.autosetuprebase = "always";
|
|
init.defaultBranch = "master";
|
|
rerere.enabled = true;
|
|
color.ui = true;
|
|
|
|
blame = {
|
|
date = "relative";
|
|
};
|
|
|
|
"color \"diff-highlight\"" = {
|
|
oldNormal = "red bold";
|
|
oldHighlight = "red bold";
|
|
newNormal = "green bold";
|
|
newHighlight = "green bold ul";
|
|
};
|
|
|
|
"color \"diff\"" = {
|
|
meta = "yellow";
|
|
frag = "magenta bold";
|
|
commit = "yellow bold";
|
|
old = "red bold";
|
|
new = "green bold";
|
|
whitespace = "red reverse";
|
|
};
|
|
};
|
|
|
|
diff-so-fancy.enable = true;
|
|
};
|
|
}
|