mirror of
https://github.com/donovanglover/nix-config.git
synced 2024-11-21 15:53:32 +01:00
4d90d5cbf0
No real reason to use qutebrowser now that I've written new-tab-identity and have LibreWolf programmed declaratively. The additional complexity of having another browser installed meant that I had to deal with a pyqt6 build error for an application I rarely used for a number of reasons (no https by default etc.)
19 lines
546 B
Nix
19 lines
546 B
Nix
{
|
|
xdg.mimeApps = {
|
|
enable = true;
|
|
|
|
defaultApplications = {
|
|
"text/html" = "librewolf.desktop";
|
|
"text/markdown" = "nvim.desktop";
|
|
"text/plain" = "nvim.desktop";
|
|
"image/png" = "pqiv.desktop";
|
|
"image/jpeg" = "pqiv.desktop";
|
|
"image/gif" = "pqiv.desktop";
|
|
"application/pdf" = "org.pwmt.zathura-pdf-mupdf.desktop";
|
|
"application/x-wine-extension-osz" = "osu-stable.desktop";
|
|
"x-scheme-handler/http" = "librewolf.desktop";
|
|
"x-scheme-handler/https" = "librewolf.desktop";
|
|
};
|
|
};
|
|
}
|