mirror of
https://github.com/donovanglover/nix-config.git
synced 2024-11-21 15:53:32 +01:00
da1ade1e6f
Now with album art support.
25 lines
357 B
Nix
25 lines
357 B
Nix
{ config, pkgs, ... }:
|
|
|
|
let
|
|
inherit (config.xdg.userDirs) music;
|
|
|
|
musicDirectory = music;
|
|
in
|
|
{
|
|
home.packages = with pkgs; [ rmpc ];
|
|
|
|
services.mpd = {
|
|
enable = true;
|
|
inherit musicDirectory;
|
|
|
|
extraConfig = ''
|
|
audio_output {
|
|
type "pipewire"
|
|
name "PipeWire Sound Server"
|
|
}
|
|
|
|
auto_update "yes"
|
|
'';
|
|
};
|
|
}
|