nix-config/home/xdg-user-dirs.nix
Donovan Glover 4b5d240ebd
meta(home-manager): Determine isPhone from nixosConfig
Simplifies things a bit since we no longer depend on a phone variable,
thus making the individual files easier to copy/paste.
2024-09-08 23:14:43 -04:00

28 lines
773 B
Nix

{ config, nixosConfig, ... }:
let
inherit (config.home) homeDirectory;
isPhone = nixosConfig.programs.calls.enable;
in
{
xdg = {
userDirs = {
enable = true;
createDirectories = true;
templates = null;
publicShare = null;
desktop = homeDirectory;
download = if isPhone then homeDirectory else "${homeDirectory}/";
documents = if isPhone then homeDirectory else "${homeDirectory}/";
music = if isPhone then homeDirectory else "${homeDirectory}/";
pictures = if isPhone then homeDirectory else "${homeDirectory}/";
videos = if isPhone then homeDirectory else "${homeDirectory}/";
};
configFile."user-dirs.locale".text = "ja_JP";
};
}