mirror of
https://github.com/donovanglover/nix-config.git
synced 2024-11-21 15:53:32 +01:00
4b5d240ebd
Simplifies things a bit since we no longer depend on a phone variable, thus making the individual files easier to copy/paste.
28 lines
773 B
Nix
28 lines
773 B
Nix
{ config, nixosConfig, ... }:
|
|
|
|
let
|
|
inherit (config.home) homeDirectory;
|
|
|
|
isPhone = nixosConfig.programs.calls.enable;
|
|
in
|
|
{
|
|
xdg = {
|
|
userDirs = {
|
|
enable = true;
|
|
createDirectories = true;
|
|
|
|
templates = null;
|
|
publicShare = null;
|
|
|
|
desktop = homeDirectory;
|
|
download = if isPhone then homeDirectory else "${homeDirectory}/ダウンロード";
|
|
documents = if isPhone then homeDirectory else "${homeDirectory}/ドキュメント";
|
|
music = if isPhone then homeDirectory else "${homeDirectory}/音楽";
|
|
pictures = if isPhone then homeDirectory else "${homeDirectory}/画像";
|
|
videos = if isPhone then homeDirectory else "${homeDirectory}/ビデオ";
|
|
};
|
|
|
|
configFile."user-dirs.locale".text = "ja_JP";
|
|
};
|
|
}
|