forked from extern/nix-config
9ed706c2a5
The white flash when starting hyprland is a deal breaker for me personally and I'd rather not have to deal with it. Should hopefully be fixed in a later release since it seems to be a wlroots issue.
21 lines
363 B
Nix
21 lines
363 B
Nix
{ pkgs, ... }:
|
|
|
|
{
|
|
services.greetd = {
|
|
enable = true;
|
|
restart = false;
|
|
|
|
settings = {
|
|
default_session = {
|
|
command = "${pkgs.greetd.tuigreet}/bin/tuigreet --time --cmd Hyprland";
|
|
user = "greeter";
|
|
};
|
|
|
|
initial_session = {
|
|
command = "${pkgs.hyprland}/bin/Hyprland";
|
|
user = "user";
|
|
};
|
|
};
|
|
};
|
|
}
|