1
0
forked from extern/nix-config
donovanglover-nix-config/modules/hyprland.nix
Donovan Glover bb3792d748
fcitx: Use wayland front-end for GTK
Fixes the warning notification shown on boot.
2024-01-13 00:39:29 -05:00

27 lines
404 B
Nix

{ pkgs, ... }:
{
programs.hyprland.enable = true;
i18n.inputMethod = {
enabled = "fcitx5";
fcitx5 = {
addons = with pkgs; [ fcitx5-mozc ];
waylandFrontend = true;
};
};
security.pam.services.swaylock = { };
services.udisks2 = {
enable = true;
mountOnMedia = true;
};
services.xserver = {
enable = true;
excludePackages = [ pkgs.xterm ];
};
}