forked from extern/nix-config
8242938fc9
This fixes an issue where nixFlakes (the stable version of Nix) would fail when running nixos-rebuild if a path contained non-ASCII characters.
14 lines
238 B
Nix
14 lines
238 B
Nix
{ pkgs, ... }:
|
|
|
|
{
|
|
nix = {
|
|
package = with pkgs.nixVersions; nix_2_19;
|
|
|
|
settings = {
|
|
experimental-features = [ "nix-command" "flakes" "repl-flake" ];
|
|
auto-optimise-store = true;
|
|
warn-dirty = false;
|
|
};
|
|
};
|
|
}
|