1
0
forked from extern/nix-config
donovanglover-nix-config/specializations/plasma.nix
Donovan Glover 8fa673095e
meta: Move DE-specific config to specializations
Helps keep the modules directory specific to the main configuration and
not any specializations.
2023-07-10 21:12:48 -04:00

31 lines
495 B
Nix

{ pkgs, lib, ... }:
{
services.xserver = {
enable = true;
desktopManager = {
plasma5.enable = true;
};
displayManager = {
sddm.enable = true;
autoLogin = {
enable = true;
user = "user";
};
};
excludePackages = [ pkgs.xterm ];
};
systemd.services = {
"getty@tty1".enable = false;
"autovt@tty1".enable = false;
};
programs.hyprland.enable = lib.mkForce false;
services.greetd.enable = lib.mkForce false;
}